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There is no getting around it, forms drive organizations. Without them, we’d have no input, no information, no data, no direction.
Organizations need forms and like it or not, most organizations rely on their administrative professionals to create them. Should it
be a Word form? How about Excel? When should you think about creating a PDF form? What about a Web-based form? Each
format has its strengths and its weakness. In this session, we’ll explore criteria you can use to decide which software tool to use to
create different types of forms. We’ll also demonstrate the steps to creating forms in Microsoft Word, Microsoft Excel, and
Adobe Acrobat. By the end of this session, you’ll know which tool to choose and how to go about creating the best form for the
job.

Defining the form

For any form to be effective, you must first be clear about its purpose. Some common questions you might ask before creating a
form are:

e  What is the purpose of the form?

e What data needs to be collected?

o Who will complete the form? Will it be completed by one person or will several people need to complete sections of it?
e Who needs to review the form before it is submitted? Are approvals required?

e Do you need to aggregate the data entered into all of the forms or does each form stand alone?

Which tool should | use?

Using Microsoft Office 2003, you can create forms using any of the following programs:
(adapted from Office programs you can use to create an online or printed form in Microsoft Office 2003 Help)

Word Forms that contain complex formatting, pictures, linked objects, embedded objects, check boxes,
drop-down lists, or text areas that have specific data types, formatting, and default text. You can
also set conditions for adding data to a form, include macros that run automatically, and provide
Help messages that make it easier for others to complete a form

Excel Create a form to collect information for use in calculations, analysis, or financial documents.
Access Same features as Word forms but you can also include Visual Basic for Applications code that runs
automatically, and you can provide ScreenTips that also make it easier for users to complete forms.
Use Access when you need to collect and store a lot of data, when you need full relational database
capabilities, when you want to generate a variety of reports from your data, or when you want to tie
your forms together into a program.

FrontPage Create a form on a Web page to collect information from site visitors or to let visitors search for
information on your Web site.
Outlook Customize mail messages, appointments, and any other Outlook item as an easy way to distribute

and collect information electronically. By using Outlook forms, you can group and sort the
information you collect, respond to information, and view information by conversation so that
responses to the form are grouped with the original form.

InfoPath Dynamic, XML based forms that can contain common controls such as text boxes, check boxes,
drop-down lists, and date pickers, as well as new controls such as repeating tables repeating
sections, and optional sections. You can specify the data types allowed in the controls, as well as
set data validation and conditional formatting. You can create different views of the form based on
user and printing needs, enable multiple forms to be merged together, and design forms so that they
can be submitted directly into a database or Web service. You can also create custom task panes,
toolbars, dialog boxes, and menus for use when people fill out a form.




Creating forms in Microsoft Word

You can create electronic forms in many of the Office applications. But forms created in Word have a winning advantage over
forms created in the other applications: a vastly larger number of potential users. Word is the most used office application, and
might be the only application other than Solitaire that home users are comfortable with. If you’re creating forms to email to a
diverse group of users, Word is your best bet.

Fortunately, it’s easy to create forms in Word. Here are the steps:
e  Use tables to layout the form.
Use borders and shading to create lines and boxes for users to enter information.
Add form controls from the Form toolbar.
Protect and lock the form.
Distribute the form.

Some users assume you need Excel if your form includes formulas, but this isn’t true. Word forms support basic calculations:
Addition (including a SUM function), Subtraction, Multiplication, and Division. If your form must include complex formulas (for
example, a form that estimates mortgage payments), use Excel. But for simple arithmetic, Word is sufficient.

Understanding the Word form controls
Choose View > Toolbars or right-click any toolbar to display the shortcut menu. Choose Forms to display the Forms toolbar.

Word’s Forms toolbar

Text Form Field Draw Table Reset Form Fields

Drop-Down Form Field Insert Frame

Form Field Shading
Form Field Options

Check Box Form Field Insert Table Protect Form

There are two sets of form controls in Word. While the Control Toolbox includes many additional control types, all the controls
require Visual Basic to actually do anything. For this session, we’ll limit ourselves to the Forms control set, which includes three
form-field controls:

Name Description Example

Text Form Field Text data: letters, numbers, dates | User name, birth date, account
number, city

Check Box Form Field Logical data Any yes/no choice: “Call me” or
“l am over the age of 18”

Drop-Down Form Field A list of text choices State names, credit card types




Using tables as your form’s foundation

Tables have two roles in forms: layout and data entry areas. Use tables as you would when creating a Web page: to align form
elements like text and images. Display and hide cell borders to create data entry areas in your form. Why use cell borders?
Because the borders don’t move, which isn’t true of line objects (created with the Drawing tools) or underscores:

Email:

If you’re beginning with an existing form, start by analyzing the form to determine how many rows and columns are required to
display the labels (text) and blanks needed in the form. Include a column for each column of data or labels, as well as extra
columns to provide vertical spacing. For example, this section of the form will need 7 columns:

Date [Spacer Item [Spacer $ Amount [Spacer GL Account 3
column] column] column]

Date

Spacer column
Item

Spacer column
$ Amount
Space column
GL Account 3
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Don’t worry too much about the rows -- you can add rows easily later without messing up your form’s layout. Some forms are
easier to create as a series of tables. Analyze each section to determine the number of columns required before creating the tables.

Providing user clues with borders and shading

After creating the tables and adjusting columns (don’t forget to use the Merge Cells and Split Cells features on the Table menu!)
enter data in the appropriate cells. As an example, here’s the table that provides the top section of our form. We’ve added borders
and shading so you can see the blank rows and extra cells, inserted to provide space in the form. You need to decide how much
the form should look like a table when it’s printed/viewed on screen. Use the Borders and Shading toolbars to format the table.

Today's Date | | | Date Rec'd in Acct. |

Name/Payee |

[ ] checkif new | Street Address
address

City | State | | Zip Code |
Reason for

Expense




Adding form controls

Now it’s time to add controls to the form. For text fields, click in the form where you want to position the form field then click the
Text Box form field control on the Forms toolbar. Do the same for Check Box form fields and Drop-Down form fields.

Setting field properties
For each field, click on the field then click the Properties button, or double click the form field to open the Properties dialog box.

If the field will be used as part of a calculation, two things are ield ) B
important: first, set the type to Number or one of the Date et Fodu Pl Uptions ‘
types. Then, give the field a really good bookmark name. For Text form fisld
example, in our form all the Expense Amount fields are named

. . Type: Default text:
ExpN so we could easily use the names later when creating the
formulas to calculate total expenses. |F<99L"5'r uzHs ﬂ “

Maximum length: Text format:

Adding calculated fields

For calculated fields, choose the Calculation type. In the
Default Text text box, enter a formula using the bookmark
names. For example, to add Expl and Exp2, enter the formula
=Expl+Exp2 |
The order of operations works here, so if a formula includes
multiplication/division and addition/subtraction, use
parentheses to indicate when addition/subtraction should occur
before multiplication/division.

Enabling calculation

After adding the calculated fields, you’ll need to set the
properties for fields that should trigger a calculation. Open the
Properties and enable the Calculate On Exit checkbox.
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Fun macra an
Entry:
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Field settings
Bookmark:

[v Fill-in enabled
[ calculate on exit

Add Help Text... | (0] 4 | Cancel

Locking your form
To lock the form, click the Protect Form button on the Forms toolbar. When the form is locked, users tab from field to field --

easy for them, easy for you. Lock the form, and then check the tab order.

Navigation tips
With complex forms, you might want to change the Tab order so that when you leave field X, the insertion point moves to field J.
To do this, you must record a macro that goes to field J, then assign that macro as an action when exiting field X. Here are the

steps to record the macro:
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Make sure you know the name of the field you want to go to.
Choose Tools > Macro > Record New Macro.

Name the macro -- for example, GoToFieldJ.

Change the Save In location to the current document.
Choose Edit > GoTo from the menu.

Choose Bookmarks. Select field J from the list of Bookmarks.

Click OK to go to the field.

Click the Stop button to save the macro.

Now, open the properties for field X. In the Exit drop down, choose your macro. Click OK.



Distributing your form

If you created the form for your own use, save it as a template. Choose File > Save As and choose Template from the Save As
Type drop down list. Word immediately switches to your templates folder so you can save the form as a template. When you
choose File > New and select the template, Word opens a copy. If you created the form to email to others, save it as a regular
Word document.

_ Field 21X
Other fields you can add to forms _ _ _ 2%
. i i Please choose a field Field properties Field options
A form can use any of the fields included in Categories: MNew narme;
Word. For example, rather than making the user | [eiy ~
enter her name, you can insert the UserName Eekl ree e
field in the appropriate place in your document. SkipIt B
StyleRef
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To add a Word field, position the insertion point | |symbol

TA

and choose Insert > Field from the menu to L Na field options available for this field

) . |
open the Insert Field dialog box. Tt =
Title
Scroll to the field you want to insert. Set ik
formatting options (if any), then click OK to it —
insert the field. UserIntiaks
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Press Alt+F9 to toggle between the field codes
and results.

Description:
Name from Tools Options User Info

Field Codes

[V Preserve formatting during updates

]

Cancel

For information on creating forms using VB and
the Control Toolbox, see this article:
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnword2k2/html/odc_activex.asp

Excel forms

To create an Excel form, activate the Forms toolbar (View > Toolbars > Forms). The tools are similar to Words but include a
couple of additional controls, such as Combination List-Edit.

Cormbo Box
Button Combination List-Edit
- Check Box i
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Edit Code
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Label
Llst Box
Grnup B / /Scrnll Bar

Option Button Combination Drop-DCiown
Contral Properties

To create a quick data entry form, click Data » Form.



Creating Adobe Acrobat PDF forms

Why PDF?
e Exchange nearly any type of document
e Password-protect and digitally sign a document
e  Set options that prevent it from being copied, edited, or printed
o Insert hyperlinks and bookmarks for simpler navigation through large documents
e Nearly everyone has a program for viewing PDF files

e Adobe Systems has given out over 500 million copies of its free PDF reader, Adobe Reader.

PDF-maker software
e Adobe Acrobat Standard ($299)
e Adobe Acrobat Professional ($449)

e Adobe opened the source code so many products are now available.

Creating a PDF document
e It’s as simple as printing!
e PDF makers install a printer driver on your computer.
e To create a PDF, choose the PDF maker as the printer and print the document.

e You are prompted to save the document to a file location.

Create online forms
1. Layout aform in Word using tables.
Print the form as a PDF.
Open the PDF in Acrobat.
Click the Form tool.
Drag a box where you want the form field to appear.
Enter the properties of the field.

Press Enter to create the field.

© N o o ~ w D

Press the Hand tool to switch out of Form view.

Form tips
e Turn on gridlines and snap before creating fields.
o View > Grid and View » Snap To Grid.
e To create rows of fields as in an expense report:

1. Create the first row.



2. Hold Shift and drag a box around the row.
3. Hold Ctrl and drag the selection box to the size you want and then click. The table fills with cells.

e Settab order (Tools » Forms > Fields »Tab Order) by clicking the cells in order.

General Acrobat tips
e Get agood head start before attempting a cartwheel.
e  Stick your tumbling runs to avoid deductions.

e Mount and dismount are not the same — know the difference!

(Just wanted to see if you were awake!)

More useful Acrobat tips
e Set Document Open Options to control how a form opens (File > Document Properties > Open Options).

e  Set Document Security options to prevent readers from printing, copying or changing the document (File > Document
Security and choose Acrobat Standard Security).

A new type of form: InfoPath Forms

What is InfoPath?
InfoPath is a new form creation tool that is part of the Microsoft Office System 2003, included in the Enterprise edition of
Microsoft Office 2003. In InfoPath, you can do two things:

e Design forms. You can design and publish interactive, user-friendly forms in design mode. In addition to inserting text
boxes and other standard controls into a form, InfoPath lets you insert controls that offer users the flexibility to add,
remove, replace, or hide sections of a form. The forms you design can range from simple forms for collecting data to
complex forms that are part of a larger business process. InfoPath forms can be used on their own, or you can design
them to work with existing databases or Web services. Forms can be published to and accessed from a common location
on a company network, such as a shared folder, a Web server, or a form library located on a Microsoft Windows®
SharePoint™ Services site. To fill out forms, users must have InfoPath installed on their computer.

e Fill out forms. InfoPath users can fill out forms by using familiar document-like features. For example, they can check
spelling inside fields, use the Format Painter tool to copy and paste formatting, or insert formatted text and graphics
inside certain fields on the form. Depending on the form's design, users may also be able to merge data from multiple
forms into a single form or export data to other programs. Users can also save forms to their computer, work on them
offline, and then submit them to the corporate network when they are reconnected. This is especially useful for people
who have intermittent or limited access to network resources, such as employees who travel frequently.

Based on XML

InfoPath is based on Extensible Markup Language (XML), a condensed form of Standard Generalized Markup Language
(SGML) that enables developers to create customized tags that offer flexibility in organizing and presenting information. When
you design a form, InfoPath creates an .xsn file, which is simply a cabinet (.cab) file containing standard XML files, such as XML
Schema (XSD) that defines the structure of an XML document, and XSL Transformation (XSLT), a language that is used to
transform XML documents into other types of documents, such as HTML or XML files. When a user fills out a form in InfoPath,
the data in that form is saved or submitted as industry-standard XML. However, you don't need to know anything about XML in
order to design or fill out an InfoPath form. The important point is that the form's XML format can make it much easier for an
organization to repurpose data. For example, a single InfoPath trip report form can be used to provide XML data to a customer
relationship management (CRM) system, a petty cash system, and a travel planning system.



Sample Microsoft InfoPath form

Employee Requisition Form

Position Information

Jab title:

Department: |Select... [v]
Contact person; Ext.:

Salary Range: Salary grade:

Position Type: O Mew position O Replacement position

Status: O Full-time O Part-time

Work schedule: [ manday [ Tuesday [ wednesday [ Thursday [ Friday

Hours: Date Meeded:

Recruitment Information
Supervisor
Last name: First name:

Telephaone: E-mail address:

Summary of duties and responsibilities:

Fequired skills, knowledge, abilities and competencies

E Insert additional required skills, knowledge, abilities and cormpetencies

asdditional preferred skills, knowledge, ahilities and competencies

I Inzert additional preferred zkills, knowledge, abilities, and competencies

Required licenses, certifications, degrees or credentials

I Insert additional licenses, certificaitons, degrees, or credentials

o Click here to attach documents
Approval

This request is
O spproved
O Mot approved

Department Head Signature Date
HR Tracking

Job number:
Title code: Approved title:
Mo, of Applicants: Date Filled:

Marne of hire: First Marme: Last Mare:

For materials and links from this session, visit our web site

www.triadconsulting.com/events/iaap.htm
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