
® All Rights Reserved, TRIAD Consulting, www.triadconsulting.com            Page 1 of 12 

Session 120 Access for Excel Power Users 
Track: Mastering Technology 
Gini Courter and Annette Marquis, Triad Consulting 
 
Description: Microsoft Access 2003 gives you the power to relate data from two separate tables, create 
customized data entry forms, query data from multiple tables and print detailed and summary reports. If 
you are already an Excel power user, you can apply your Excel skills to building a relational database 
that will take your database solutions to the next level. In this workshop, you’ll learn how to: 
 
• Differentiate a relational database from an Excel list. 
• Use the rules of normalization to design well-structured relational databases. 
• Design tables that comply with the database rules of normalization. 
• Write queries to extract information based on criteria you determine. 
• Develop forms to enter and access data easily. 
• Design reports that provide clear and timely information. 

Microsoft Access – the Office relational database 
from GCF Tutorial: http://www.gcflearnfree.org 

A relational database is a formal way to enter, organize, analyze, and report on data. It is easy to 
maintain. It manages information and then shares it with other tables and databases. For example, let’s 
look at a relational database address book.  

Many entries in your address book 
will contain the usual contact 
information -- name, address, city, 
state, zip code, and phone number. 
This information might be stored in 
a table called the Contacts table. 

You may want to structure your 
address book so that family 
members are separated from 
companies called during an 
employment search, for example. 
These categories -- family, friend, 
relative, company -- might appear in 
a second table called Contact 
Types. 

Maybe you want keep notes for certain interactions with contacts. This information -- -- date, time, and 
notes, for example -- can be saved to a third table called Calls.  

The Contact Types table offers little information on its own. Contact Types is a lookup table, used to 
provide consistent information to organize the Contacts table. 
When you relate Contact Types to the Contacts table -- name, 
address, and phone -- then you can sort or filter contacts by 
category. The Contact Types table is only useful when related 
to the Contacts table. 

http://www.gcflearnfree.org/
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Similarly, by relating the Calls table with the Contacts table you 
can relate specific phone calls to specific people.   

There are two reasons a relational database like Access is 
powerful:  

1) information is managed in separate tables to avoid 
duplicate entries, making maintenance easier,  
2) data can be combined by relating different tables. 

 
Database tables are created with fields and records. In the Contacts table, the columns like name, 
address, city, state, and phone are fields. All of the information for one contact is a record.  

The tables in a database are related with primary keys – a field (or combination of fields) that will be 
unique for each record. For example, in the Contacts table the primary key may be a Contact ID or a 
combination of Last Name, First Name, and Phone Number. In the Calls table, the primary key might be 
the Contact ID from Contacts and the Date and Time fields.  

NOTE: Access will allow you to create a database table without primary keys. Don’t do this. Primary keys 
are absolutely critical.  

Parts of an Access Database 
A Microsoft Access database is made up of 
database objects including: tables, forms, 
queries and reports.  All database objects are 
stored in the same Access database (mdb file 
extension). 

What is a Table? 

Data is stored in one or more tables. Separate 
tables are usually created for specific topics, such 
as products or suppliers. Tables can be related to 
one another to access the different types of 
information. Because data is stored only once -- 
you probably would not save the same information 
in two different tables -- your database becomes 
more efficient. 

The columns and rows in an Access table 
resemble an Excel spreadsheet. Tables organize 
data into columns (called fields) and rows (called records). A record is comprised of one or more fields, 
depending on the number of fields defined to the 
table.  

Individual fields in an address book table might 
consist of name, street address, city, state, zip 
code, and phone number. A single record is an 
entry that uses all these fields, such as your 
brother or sister's contact information. 
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What is a Query? 

A query lets you find and retrieve information from one or more tables based on a set of search 
conditions you define (e.g., certain fields in one or more tables). The results can be displayed in a 
manner of your choosing. Queries can be created using a wizard or developed from scratch in the Query 
Design view. 

What is a Form? 

A form can be created to view, input or change information in one or more tables. In this course, we will 
see how forms are used as both menus and as data entry forms to database tables. Forms can retrieve 
data from one or more tables, and display the output on the screen. 

 

What is a Report? 

A report is an effective way to analyze and present data in a printed format using a specific layout. You 
have control over the size 
and appearance of 
information printed on the 
report, similar to 
formatting you perform in 

a 
Microsoft 
Word 
document. 

The Database window 
The Database toolbar presents operations that can be performed against different 
database objects, including buttons to open, design, create or delete an object. 
Database objects are created and opened by choosing any of the buttons listed in the left 
pane of the database window. Any of the first four options -- Tables, Queries, Forms, or 
Reports -- opens additional choices 
related to that selection in the right pane. 
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Rules of Database Normalization  
from Wikipedia - http://en.wikipedia.org/wiki/Database_normalization and databases.about.com 
 
Normalization is the process of efficiently organizing data in a database. There are two goals of the 
normalization process: eliminating redundant data (for example, storing the same data in more than one 
table) and ensuring data dependencies make sense (only storing related data in a table). Both of these 
actions reduce the amount of space a database consumes and ensure that data is logically stored.  

The Normal Forms 
• The database community has developed a series of guidelines for ensuring that databases are 

normalized. These are referred to as normal forms and are numbered from one (the lowest form 
of normalization, referred to as first normal form or 1NF) through five (fifth normal form or 5NF). In 
practical applications, you'll often see 1NF, 2NF, and 3NF.  
 

First Normal Form (1NF) 
First normal form (1NF) sets the very basic rules for an organized database:  

• Eliminate duplicative columns from the same table.  
• Create separate tables for each group of related data and identify each row with a unique column 

or set of columns (the primary key).  
Second Normal Form (2NF) 
Second normal form (2NF) further addresses the concept of removing duplicative data:  

• Meet all the requirements of the first normal form.  
• Remove subsets of data that apply to multiple rows of a table and place them in separate tables.  
• Create relationships between these new tables and their predecessors through the use of foreign 

keys.  
Third Normal Form (3NF) 
Third normal form (3NF) goes one large step further:  

• Meet all the requirements of the second normal form.  
• Remove columns that are not dependent upon the primary key. 

Creating and Modifying Access Tables 
If you have a data set that has or will soon have more than 65,535 records, you’ll run out of rows in 
Excel, so you must put the data in an Access table. Just as Excel lists live in Excel workbooks, Access 
tables live in Access databases. Before you can create a table, you must create a database to store it in. 
 
Follow these steps to create a blank Access database: 

1. Start Access. 
2. In the New File section of the task pane click the Blank Database link to open the File New 

Database dialog box. 
3. In the dialog box enter a location and database name and then click Create. Access saves the 

database and opens the database window. If you’re looking at forms, reports, queries, or some 
other type of object, click the Tables icon in the Objects bar.  

 
Three table-creation methods are shown: 

• Create Table In Design View 
• Create Table By Using Wizard 
• Create Table By Entering Data 

 
To create a table with fields commonly used in business, begin with the Table Wizard, which includes a 
variety of tables and fields. Fields chosen from the wizard include useful extras. For example, if you 
choose a phone number field from the Table Wizard, the field is already formatted with the parentheses 

http://en.wikipedia.org/wiki/Database_normalization+and+databases.about.com
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and hyphens used to format a telephone number. After finishing the wizard you can further modify the 
table in Design view. At that point you also have the options of entering data either directly or via a form 
the wizard creates. For tables that include fields specific to your organization only, start in Design view. In 
Design view, you enter field names and specify all the properties of each field. 
 
We’d encourage you to simply ignore the third choice, Create Table By Entering Data. It’s very limiting: 
you can change the names of fields, add lookup columns, enter data, and that’s about it. Access assigns 
attributes to the fields, sometimes incorrectly. You get the idea: use Design View or the Table Wizard. 
We’ll tackle the Table Wizard first. Before we do, we need to discuss one table design element: primary 
keys. 
 
Choosing (or Not) a Primary Key for a Table 
A primary key is the field (or set of fields) that is unique and can, therefore, be used to identify one 
record in a table. For example, when you need to find a specific book on amazon.com, a search by 
the primary key for books, the ISBN, will find the single correct result. Examples of data that serve 
as primary keys include the following: 

• Social Security numbers, student numbers, and employee numbers for people 
• Product numbers (SKUs or UPCs) for products 
• ISBNs for books 
• FEINs for U.S. companies 
• Vehicle numbers (VINs) for cars and trucks 
• Credit card and bank account numbers 

When a field is set as the primary key, Access won’t allow you to enter a duplicate value. In the 
Amazon.com database, if an employee tries to enter an ISBN that has already been entered, the 
database will kick it back and ask for a new ISBN. In this way, primary keys help prevent accidental 
duplicate data entry. 
 
If you’re creating a database that will have only one table, a primary key isn’t absolutely necessary,  
but it’s still a good idea to include one. In a relational database with more than one table, however, 
every table must have a primary key for multi-table queries, reports, and forms to work properly. 
When a single field can’t serve as a primary key, it’s OK to create a key by using two or three fields. 
If no combination of fields is unique, include a field with the AutoNumber data type to use as a 
primary key. 
 
Creating a Table Using the Table Wizard 
The Table Wizard is a fast way to create a table. As with most Office wizards, the Table Wizard offers 
limited choices that are prepackaged. When you choose a field in the wizard, you’re also choosing other 
settings related to the field. The wizard includes sample tables and fields; browsing the lists may prompt 
you to include other useful fields in your table. To create a table using the Table Wizard, double-click 
Create Table By Using Wizard on the Tables tab of the Database window. 
 

1. In the first step of the wizard, choose a category option, Business or Personal, and select a table 
from the Sample Tables list that’s similar to the table you want to create. 

2. To include a field from the Sample Fields list, double-click the field name or use the pick buttons 
(with the arrows) to move the field to the list of Fields In My New Table. 

3. To rename a field, select the field in the Fields In My New Table list. Click the Rename Field 
button to open the Rename Field dialog box. Enter a name for the field, and click OK. 

4. Continue selecting tables and fields for your table. When you’ve selected all the fields you want to 
include in this table, click Next. 

5. In the second step of the wizard, type a name for your table and select a primary key option. 
a. If you let Access set the primary key, it adds an AutoNumber field to the table. Do this if none of 
the fields you selected can serve as a primary key. Click Next. 
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b. Choose No, I’ll Set The Primary Key if the fields you selected include a field you want to use as 
the primary key. Click Next to advance to the next step of the wizard. Select the key field from the 
list of fields in your table and choose the data type for that field using the option buttons. Click 
Next. 

6. 6. In the last step of the wizard, you have three choices. You can select Modify the Table Design 
to open the finished table in Design view (so you can further tweak the design); you can select 
Enter Data Directly Into The Table (so you can start entering data in Datasheet view); or you can 
let Access automatically create and display a form that will allow you to enter data into the table. 
Select the option you want, and click Finish. 

 
If there are other tables in your database, the last step of the wizard prompts you to create relationships 
to the existing tables. If this is the first table in your database, you won’t be asked about relationships. 
Access saves the table design and opens the table so you can begin entering data. Use tab to move 
from one field to the next, and to move from the last field in a record to the next record. When you’re 
finished entering data, close the table. Access automatically saves your data. 
 
Creating a Table in Design View 
When you can’t find the fields you need in the Table Wizard, you can create a table from scratch (or 
modify a table you created in the wizard) in Design View. Double-click the Create Table In Design 
View to open a new table in Design view. Follow these steps to create a table: 
 

1. Type the field name for the first field. If your table will include a primary key, enter that field first, 
then right-click the field name and choose Primary Key from the shortcut menu. Field names 
should be descriptive and as unambiguous as possible. The convention is initial caps, no spaces 
(like LastName), but spaces are allowed. 

2. Press Tab to move to the Data Type column. Select a data type from the drop-down list. You can 
select a data type from the list by typing its first letter; for example, if you know you want a 
Number data type, type n. 

 
The data type describes and limits the kind of data that can be entered in the field. If, for example, you 
select the Number or Currency data type for a field, users won’t be able to enter any character other than 
a digit, minus symbol, plus symbol, decimal point, or dollar sign. Choose the data type that reflects the 
type of data you want users to be able to enter in the field. There are 10 items on the Data Type drop-
down list: 

•••• Text Used for both words and numbers that won’t be used in calculations, such as phone 
numbers and Social Security numbers. The maximum length for a Text field is 255 characters. 
Text is the default data type because it is used most frequently. 

•••• Memo An open field that is used for comments. Although you can enter more characters than you 
can with a Text field (65,536), you can’t easily sort or filter on a Memo field, so use this field type 
sparingly. 

•••• Number Numbers that are negative or positive values; unlike Excel, Access does not treat dates 
as numbers. 

•••• Date/Time Dates, times, and combinations of the two. 
•••• Currency Numbers in dollars or in dollars and cents. 
•••• AutoNumber A numeric field automatically entered by Access; it is used for a primary key field 

when none of the fields in a table is unique. 
•••• Yes/No A logical field that forces a user to choose one of two values. Data in this field can be 

displayed in different ways: Yes or No, On or Off, True or False, or with a check box. 
•••• OLE Object An object, such as a photograph, a bar code image, or a document, that was created 

in another application. 
•••• Hyperlink URLs and e-mail addresses. 
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•••• Lookup Wizard Not really a data type, this is used to create a lookup field, which lets the 
database user select a value from a list, enhancing data accuracy by preventing typos. 

 
3. Tab to move to the Description area. Enter a description for the field if you wish.There are two 

uses for the description. While you’re creating a database, this is a fine place to keep your notes. 
When the database is completed and you’re ready to let others use it, the field descriptions 
provide a passive help system. When a user moves to a field in a table or form, the text in the 
description appears in the status bar. If you’ve used the descriptions for your own notes, you can 
either turn off the status bar display or return to Design view to clean up the descriptions.  

4. Press Enter or Tab to drop to the next blank row and enter the information for the next field. 
Continue until you have entered all fields. 

5. Click the Save button on the toolbar or choose File � Save to save the table. Enter a table name 
when prompted. Close the table or click the View button to switch to Datasheet view and begin 
entering data. 

 

Importing and Exporting in Access 
Access 2003 can turn almost any data file into an Access database table. If you choose File > Open to 
open an existing data file, the Open dialog box shows multiple data file types (Excel spreadsheets, other 
database types, text files) in the folder. Opening a file created in an application like Excel starts the Link 
Spreadsheet Wizard, which guides you through setting up a new database based on the data file. The 
new database contains a single table, linked to the original file, so you can use the data in Access without 
duplicating data.  
 
Importing vs. Linking 
Importing data creates a copy of the data in a table in your database. Because a copy is created, the 
original data isn’t affected, and further changes in the original data are not reflected in Access. With 
linked data, you are working with original data; when the source file changes, the changes are reflected 
in Access, and changes you make in Access are reflected in the source file. 
 
Before you can bring external data into your Access database via importing or linking, you need to decide 
which method you want to use. For example, let’s say that you’re creating a new database, and a 
colleague in another department offers you an Excel spreadsheet that lists all the cities, states, and zip 
codes for your region. Should you import or link? If you know that the spreadsheet isn’t routinely updated, 
you should import it. Cities, states, and zip codes rarely change, so updating isn’t an issue with this data.  
When you import data, you can change field properties and rearrange or delete fields if you need to, so 
importing is more flexible from your point of view.  
 
Contrast this with an Excel spreadsheet maintained by the Purchasing Department that lists current 
products in the inventory. New products are constantly added, and products are removed. You don’t want 
salespeople who use your database to sell products you no longer carry, or fail to sell products that are in 
stock. You should link to this spreadsheet so your users always have access to current data.  
 
Importing Data  
To import external data, choose File > Get External Data > Import to open the Import dialog box. Select 
the type of file you want to import from the Files Of Type drop-down list. Locate and select the file, and 
click Import.  
 
Importing Data from Spreadsheets and Other Databases 
You can easily import data from Excel or Lotus 1-2-3. (Other spreadsheet filters are available with a 
custom Office installation.) To do so, follow these steps: 
1. Choose File > Get External Data > Import to open the Import dialog box.  
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2. Select the file you wish to import. Click the Import button. (If you can’t see Excel or Lotus files, 
change the Files Of Type drop-down list at the bottom of the Import dialog box.)  

3. If you’re importing from an Excel workbook with more than one named range or worksheet, you are 
prompted to select a worksheet or range. Select the range or worksheet you want to import, and click 
Next.  

4. In the next step of the wizard (the first step you see if there is only one data source in the file you 
selected), indicate whether the spreadsheet’s first row is data or column labels. Click Next. If some of 
the column headings aren’t valid Access field names, Access notifies you that it will convert the 
names (using names like Field1, Field2, etc.). If you’re importing this data into a new table, you can 
change these names in Design view after importing the data. If you intend to import the data directly 
into an existing table, however, this is a problem. Cancel the wizard, make sure the column headings 
in the spreadsheet match the field names in the existing table, and start again. 

5. In the next step, choose whether you want Access to create a new table with this data or place it in an 
existing table. If you choose an existing table, the column labels in the spreadsheet and the field 
names in the table must be identical. Click Next. 

6. If you’ve chosen to import the data into a new table, the next step of the wizard allows you to indicate 
whether the data in each column is indexed; you can omit any columns of data you don’t want by 
enabling the Do Not Import Field (Skip) check box. Click Next. 

7. In the next step, choose whether to have Access add an AutoNumber primary key (not always the 
best idea), select an existing column as the primary key, or indicate that there is no primary key field. 
If the primary key includes more than one field, choose No Primary Key Field, and set the primary key 
in table Design view after you’ve imported the data. If you’re not sure, choose No Primary Key.  

8. In the last step of the wizard, name the table and click Finish. Access will import the data.  
 
After the table is imported, you may want to make some changes in Design view. For example, if a Social 
Security number column was imported as numbers, you’d want to change the data type to Text and add 
an input mask to speed up data entry. Numbers that won’t be calculated, such as zip codes and part 
numbers, should be changed if necessary to the Text data type to retain leading or trailing zeros.  
 
NOTE: Handling Data Import Glitches 
Access can successfully import or link only to valid databases. Most database applications can only be 
used to create valid databases; spreadsheet, text, HTML, and XML files may not be valid databases.  
When you try to import invalid data, Access reports zero records imported at the end of the Import 
Wizard. Open the file in its native application and make whatever corrections are necessary to make it a 
valid database; then resave the file and try again.  
If, for example, you try to import 50 rows of data from Excel, and Access reports that zero rows were 
imported, the Excel spreadsheet is probably not a valid Excel database. Open the Excel workbook, select 
any cell in the database range, and choose Data > Sort. Excel will select the database range or display a 
message box indicating that no list is found—that the active cell is not part of a database.  
If some, but not all, rows and columns are selected, check for blank rows or columns within the database. 
If there is no list, look for advanced formatting in the range. An Excel database can’t have merged cells; 
and multiline cells (created by pressing Alt+Enter when entering data) aren’t accurately imported. When 
you’ve corrected the Excel database, save the workbook and try importing again.  
You can also use Excel’s tools to check text and markup databases. Launch Excel and open the HTML, 
XML, or text document to see how it performs with Excel’s data tools.  
If you import from another Access database, you aren’t limited to importing just data. You can import 
forms, reports, macros, and even relationships. When you choose an Access database in the Import 
dialog box, the Import Objects dialog box opens. Click the Options button to extend the dialog box to 
show other available options.  
 
 
Linking to a Spreadsheet or Database 
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If the data you want to include from another source gets updated periodically, you should link to the data 
rather than importing it. Examples of dynamic data include lists of customers or products, price 
schedules, current course offerings, etc. Linking to a table or worksheet is even less complex than 
importing. You can’t change the structure of the linked table or worksheet, so you don’t get an opportunity 
to skip columns.  
Follow these steps to link to an external data source: 
1. Choose File > Get External Data > Link Tables. 
2. Select the type of data source you want to link to in the Files Of Type drop-down list, select the file 

you want to link to, and click Link to open the Link Wizard.  
3. If you’re linking to a spreadsheet or other non-Access file, select the worksheet, named range, or 

table you want to link to, and click Link. If you’re linking to a table or set of tables in another 
Access database, select the table name(s) and click OK. If you’re linking to another Access table, 
the table is linked and you’re finished. If you’re linking to a non-Access file, continue with step 4. 

4. In the wizard, indicate whether the first row contains data or column labels, and click Next. 
5. Enter the name you will use to refer to the external table or worksheet, and click Finish. 
You can tell which tables in a database are links to other tables. Linked Access tables have a link arrow 
in front of the Access table icon; other linked file types have their own icons with the link arrow.  
If you decide later that you don’t want to maintain the link, select and delete the link in the Table tab of 
the Database window. The link is deleted, but the original data source is not affected. 
 

Creating Access Forms 
Access forms let users enter or view data without needing to know how the database tables are designed 
or related. A form doesn’t need to include all of a table’s fields, so the form may omit fields where users 
can’t enter data, such as AutoNumber fields. A form can include data from multiple tables, providing one-
stop data entry. You can design the form so that it looks just like a physical document that serves as the 
source document—a membership application, a customer data form, or another document used to collect 
data—to make it easier for users to enter data correctly. Access provides three form-creation methods: 
AutoForms, the Form Wizard, and form Design view.  

Selecting a Form Layout 
Most data entry forms are based on one of three layouts: datasheet, tabular, or columnar. The datasheet 
form layout looks just like the table’s Datasheet view, right down to the navigation buttons. Users can 
rearrange the columns and rows using drag and drop as they would in the table’s Datasheet view. Using 
this form is a lot like working in an Excel worksheet: the arrow keys move the cursor between fields and 
records, and PgUp and PgDn scroll screen by screen.  
 
Like the datasheet form, the tabular form presents multiple records. However, the form itself looks a bit 
more polished, and movement within the form is limited. Tab and Enter allow you to move from field to 
field within each record and from the last field in one record to the first field in the next record. You’ll use 
the navigation buttons at the bottom of the form, not the arrow keys, to navigate between records. 
 
A columnar form displays one record at a time. If the primary purpose of a form is data entry or editing, a 
columnar form is best. Click the navigation buttons to move between records or enter a new record. 
 
Both the tabular and datasheet forms display multiple records. A common use for a datasheet or tabular 
form is as a subform: a form within another form. Tabular and columnar forms display each data field in a 
text box control: an editable area on a form that is bound to a field in a table. To move to the next record 
in a form, tab out of the last text box control for the current record, or simply press Ctrl+Page Down.  
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Creating AutoForms 
AutoForms are quick, no-frill forms created with a few clicks on the Access toolbars. AutoForms are 
based on a single table or query. You select the table or query and choose a layout, and Access creates 
the form. To create an AutoForm: 

1. Select a table or query in the Database Window.  
2. Choose Insert � Form from the menu; or click down arrow on the New Object toolbar button  
3. To create a columnar form, choose AutoForm. To select a form type, choose Form (not 

AutoForm) to open the New Form dialog box. 
4. Select a form layout (Autoform: Tabular, AutoForm: Columnar, or AutoForm: Datasheet) from the 

list new objects.  
5. Confirm that the table/query selected in step 1 is selected in the drop down list.  
6. Click OK to create and display the form.  
7. When you close the form, you are prompted to save it.  

AutoForms are a good choice when you need a quick form that includes all the information from a single 
table. But AutoForms are built for speed, not for comfort: AutoForms are labeled with field names rather 
than captions; all the fields are placed on the form in the order they appear in the table. If you don’t want 
to display all the fields from a table, or if you need data from multiple tables, use the Form Wizard or 
Design view to create your form.  
 

Creating Forms with the Form Wizard 
To create a form with the Form Wizard, follow these steps: 

1. Select the Forms tab in the Database window and click the New button, or choose Form from the 
drop down menu on the New Object toolbar button to open the New Form dialog box.  

2. Choose Form Wizard and click OK to open the Form Wizard. Click Next.  
3. Select one of the tables you want to use in the Tables/Queries drop-down list (tables are listed 

first, followed by queries).  
4. In the Available Fields list, double-click the fields to include, or use the pick buttons to move fields, 

in order, to the Selected Fields list.  
5. If your form will have data from more than one table, select a related table from the 

Tables/Queries drop down list. 
6. Select the fields to include from the related table.  
7. Repeat steps 5 and 6 until all fields are selected. Click the Next button. 
8. In the next step of the wizard, select how you want to view your data. If the tables have a one-to-

many relationship, you are asked how you want to view your data—which table should be the 
primary focus. If you select By [primary table], set the Form With Subform(s) or Linked Forms 
option. Click Next.  

9. If you choose fields from unrelated tables, the Form Wizard displays an error message. Close the 
wizard, set the relationships (Tools � Relationships), and start the Form Wizard again.  

10. If the form includes a subform, choose the Tabular or Datasheet format. Click Next. 
11. Select a style for the main form; Standard is recommended. Click Next. 
12. Enter names for the form (and the subform if you created one). Click Finish to create the form(s). 

 
Modifying Access Form Design 
The forms created with the Form Wizard have limited visual appeal. Fortunately Access includes many 
tools for modifying a form’s design. To switch to Design view in an open form, click the Design View 
button on the Database toolbar. To display a form in Design view, select the form in the Database 
window and click the Design button on the toolbar. You spend a lot of time switching between Design 
view and Form view as you’re working in Access. Use Ctrl+> and Ctrl+< to toggle between Form view 
and Design view. 
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The Design View window includes horizontal and vertical rulers, Form Design, Formatting, and Toolbox 
toolbars, and the Field List. The Toolbox button includes tools to add controls to the form. If the Toolbox 
doesn’t appear when you open a form in Design view, click the Toolbox button on the Form Design 
toolbar.  
 
In Design view, a form includes several sections and a number of different controls. The sections are: 
Form Header Appears at the beginning of the first page of the form and is usually used for titles. 
Form Footer Appears at the end of the last page of the form and is used for user tips or other 
miscellaneous information. 
Page Header Is used for printing information at the top of every page in a form. 
Page Footer Is used for printing information at the bottom of every page in a form. 
Detail Section Displays a record’s data. 
 
If the Form or Page Header and Form Footer bars aren’t visible and you want to use these sections, 
choose View > Form Header/Footer or View > Page Header/Footer from the menu bar to display them. 
The Detail section includes the form background and controls, including text boxes that display table data 
and labels, and the caption or field name from the table. In tabular and datasheet forms, labels appear in 
the Form Header section, and text boxes appear below the labels in the Detail section.  
 
If you want to rearrange a form, it’s easiest to begin by enlarging the form’s area. Move the mouse 
pointer to the bottom of the Detail section, just above the Form Footer. When the pointer changes to an 
adjustment tool, drag the Footer bar down to increase the height of the Detail area. To increase the 
Header section, drag the Detail bar down to make the Header area larger. Adjust the form width by 
dragging the right edge of the form.  
 
The Design View window includes an extra toolbar and rulers that aren’t displayed in Form view, so you 
can’t precisely resize the Form View window with the mouse. To resize the Form View window after you 
finish working in Design view, switch to Form view, make sure the form window is not maximized, and 
then choose Window > Size To Fit Form from the menu. 
 
Working with Form Controls 
To select a control, click it. Handles indicate the control is selected. If you click a control that’s already 
selected, the insertion point appears inside the control so that you can edit text in the control. To reselect 
the control, click anywhere outside the control and then click the control again. In Access, controls that 
display data, such as text boxes and check boxes, are bound (directly tied) to fields in the underlying 
table; labels are just text on the form and are unbound. 
To select multiple controls: 

• Move the pointer to either ruler bar. The pointer changes to a bold arrow pointing toward the form. 
Press the mouse button, and a line drops directly through the form. Drag along the ruler to select 
controls within a vertical or horizontal area. When you release the button, all the controls that the 
line passed through are selected. 

• If the controls you want to select aren’t grouped together, you can select one control and hold the 
Shift key while selecting additional control(s). 

• Starting outside any control, drag a rectangle over the controls you wish to select. Hold Shift and 
click to unselect controls that you don’t want to include in the selection.  

Delete selected controls by pressing the Delete key on the keyboard. 
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Moving and Sizing Controls 
To move a control, first select it; then move the pointer to an edge of the selected object, being sure not 
to point directly at any of the resizing handles. The pointer changes shape to a small hand. Hold the 
mouse button and drag the object to its new location. If you move an object beyond the bottom or right 
edge of the form, the form area increases.  
When you select certain Access controls—text boxes, check boxes, and option buttons—the 
corresponding label control is also selected. Point to the edge of the text box (not on a handle) to see the 
Hand pointer. Move the text box and the label by dragging the Hand. To move one control but not the 
other, point to the move handle on the upper-left corner of the text box or label control. The pointer 
changes to a finger pointing at the move handle. Drag the control to move it. 
 
When you click to select a text box, the corresponding label is only partially selected. It moves with the 
text box, but if you change the format of the text box, the label format does not change. To format the 
label, you must select it. 
Adjust the size of controls by dragging the resizing handles at the corners and sides of the object. 
Changing the size of a text box control does not change the size of its underlying field. To change field 
size, you must go to the table’s Design view and change the field size properties. For extra precision, 
select a control and use Shift+arrow keys to resize and Ctrl+arrow keys to move the control. 
 
 
 
 
Looking for Best in Class training in Microsoft Office? Come to Office BootCamp! The next 

Office BootCamp, using Office 2003 and previewing Office 2007, will be held September 

21-23 in Harrisburg, PA. For more info or to register: www.officebootcamp.com.   
 

http://www.officebootcamp.com/

