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Description: If you have lists of data in Excel and need to better understand or present the data, an Excel
PivotTable may be the tool you need. With pivot tables, you can easily summarize vast amounts of data by date
or other groupings, combine and compare data in a table, and rotate (pivot) the table’s rows and columns to see
different summaries in a flash. In this session, you'll learn how to:

Create pivot tables using the PivotTable Wizard

Modify a pivot table

AutoFormat a pivot table

Apply conditional formatting

Create a pivot chart

Change the summarization method for table data

Modify pivot table field names

Create separate pivot tables for each of the values in a column

You’ve heard of pivot tables — maybe you’ve even tried to create one, but needed help to be successful. When
you leave this session, you will be able to create and use a pivot table to answer critical questions about your
organization.

UNDERSTANDING PIVOT TABLE AND PIVOT CHART REPORTS

A pivot table report summarizes the columns of information in a database in relationship to each other. A pivot
chart is the graphical representation of a pivot table. When you need to present thousands of rows of data in a
meaningful fashion, you need a pivot table.

Tree Sales Summary

Quantity County [+]

Type [+] Genesee Kalkaska Lake Oakland| Grand Total
Blue Spruce 12,500 13,500 73,500 22,500 122,000
Concaolor Fir 20,000 10,000 12,000 13,500 55,500
Frazier Fir 6,500 7,500 14,500 15,000 43 500
Scotch Pine 41,000 - - 11,000 52,000
White Pine 37,000 - 58,500 15,500 111,000
Grand Total 117,000 31,000 158,500 77,500 384,000

Figure 1: an Excel Pivot Table Report summarizing sales data.



Tree Orders by County and Type
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Figure 2: an Excel Pivot Chart illustrating the data

Not all databases are good candidates for pivot
table analysis. Databases contain many
different types of information. Pivot tables
focus on two broad types of entries:

e Data fields that can be summarized
like Quantity, Total Cost, Miles Driven.

e Text fields that label or describe the
data such as Salesperson, Customer,
City and Sales Territory.

Figure 3: Text fields and data fields in the Excel list.
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Y Month County Type Quantity Bundles Cost
5 | Jan-08 Genesee Blue Spruce $12,500.00 $ 2500 17,475
6 | Jan-08 Oakland Blue Spruce  22,500.00 4500 31455
7 | Jan-08 Oakland Concolor Fir ~ 13,500.00 27.00 16,173
8 | Jan-08 Genesee White Pine 37,000.00 7400 44326
9 | Jan-08 Oakland White Pine 15,500.00 31.00 18569
10 | Feb-08 Lake Blue Spruce  42500.00 85.00 " 59,415
11| Feb-08 Genesee Frazier Fir 6,500.00 13.00 7,787
12| Feb-08 Oakland ScotchPine  11,000.00 2200 13,178
13 | Feb-08 Lake White Pine 32,000.00 64.00 38,336
| 14 | Mar-08 Kalkaska Blue Spruce  13,500.00 27.00 " 18,873
| 15| Mar-08 Kalkaska Concolor Fir ~ 10,000.00  20.00 11,980
16 | Mar-08 Lake Concolor Fir ~ 12,000.00 2400 14376
17 | Mar-08 Lake Frazier Fir 14,500.00 29.00 17371
18 | Mar-08 Genesee Concolor Fir ~ 20,000.00  40.00 23,960
19| Mar-08 Oakland  Frazier Fir 15,000.00 30.00 17,970
20| Apr-08 Genesee ScotchPine  41,000.00 82.00 49,118
| 21| Apr-08 Lake Blue Spruce  31,000.00 62.00 " 43338
22 | Apr-08 Kalkaska Frazier Fir 7,500.00 1500 8985
23| Apr-08 Lake White Pine 26,500.00 53.00 31,747

Text fields Data fields

|



CREATING A PIVOT TABLE USING THE WIZARD

Use the PivotTable and PivotChart Wizard to create an Excel pivot table. Select any cell in the database, and
choose Data » PivotTable and PivotChart Report to launch the wizard.

STEP 1: IDENTIFYING THE DATA SOURCE AND THE TYPE OF REPORT

In the first step of the wizard, select the type of data you want to work with:
e datain an Excel database
e data from an external source like Microsoft Access
e data that you want to consolidate from several worksheets or sources

e an existing PivotTable

Basing a PivotTable on an existing PivotTable results in a leaner file. Specify whether you want a pivot table or a
pivot table with a pivot chart.

STEP 2: VERIFYING THE DATA RANGE

In the second step of the wizard, verify the range of the database. If there is no range selected, or if the range is
incorrect, select the correct range before clicking the Next button.

STEP 3: LAYOUT AND DESTINATION

In the third step, specify the destination, layout, and options. The default destination is a new worksheet. To
place the pivot table in an existing worksheet, click Existing Worksheet. Identify a cell address for the upper-left
corner of the pivot table. Click Finish to create the Pivot Table.

CHANGING PIVOTTABLE LAYOUT

When you complete the wizard, Excel displays the pivot table, and the Pivot Table Field List. A pivot table
contains four areas.

THE ROW AND COLUMN AREAS

Place text fields you want to compare in the Row and Column areas. For example, you might want to compare
sales regions by month, or classes by quarter. When you drop a field, Excel examines the data source. Each
unique entry becomes a row or column heading—an item—in the pivot table.

THE FILTER (PAGE) AREA



While you can filter items in the Row area and Column area, the Page area is used specifically to filter the pivot
table. If you need to create separate reports for values in a specific column, place it in the Page area.

THE DATA AREA

Information in the Data area will be summarized, so numeric fields are generally placed there. If you place a text
field in the Data area, you can only COUNT the number of entries for each column and row.

As you add a field to the Data area, Excel indicates the default summary type for the data. SUM is the default for
values; COUNT is the default for columns that contain text entries, dates, or times.

TIP: If a column of numbers includes even one text entry, you can’t use SUM. You are limited to the only summary
function that applies to text: COUNT. In Excel you should never use text values like None or NA to indicate the
absence of a value. Use Replace (Edit > Replace) to replace text entries like NA with blanks; simply leave the
Replace With textbox blank.

REMOVING AND ADDING PIVOT TABLE FIELDS

You can change the layout of an existing pivot table by dragging a field button to another area. To remove a field
from the pivot table, drag the field button out of the pivot table area. A large X appears on the button. Release
the mouse button to drop and delete the field. To add a field to the pivot table, drag a button from the Field List
into the appropriate area.

TIP: You can rename fields in your pivot table. Click the field button, overtype the name in the formula bar, and
press Enter. You can't use any name that's used as a field name in your database.

FILTERING ITEMS

To filter data displayed in the pivot table, click the filter drop-down arrow on the field button for the field you
wish to filter. This opens a list of items in the field. Select the items you want to display, and then click OK to
close the list and filter the pivot table. Do you want to include this filtered table in a report you’re creating in
Word? Select and copy the filtered pivot table. Open the Word document and place your insertion point where
you want to place the pivot table. Click Paste to embed the pivot table in the Word document. Click anywhere in
the pivot table to turn on the Excel toolbars so you can format the table.

GROUPING ITEMS

Grouping combines items, and is usually used for date fields to combine them into months or years. To group a
field, right click the field and choose Group and Outline > Group from the shortcut menu to open the Group and
Outline dialog box.



The list box in the Group and Outline dialog box is a multi-pick list; choose Month if you want to group by month
regardless of year (like employee hire dates or birthdays). Choose both Month and Year, as shown at right, if the
same month in different years should be separate entries.

DRILLING DOWN IN A PIVOT TABLE

Double-click any nonzero value in the Data area, and Excel opens a new worksheet and displays the records that
are summarized in that cell of the pivot table report:

Quantity County [+]
Type [-] Genesee Kalkaska Lake Oakland| Grand Total

4

Blue Spruce | 12,500 13500 73500 22,500 0
Concolor Fir | 20,000 10,000 12,000 13,500 55,500

Frazier Fir 6500 7500 14500 15,000 43,500
Scotch Pine | 41,000 : : 11,000 52,000
White Pine 37,000 - 58,500 15500 111,000
Grand Total 117,000 31,000 158500 77,500 384,000

A | B | C | b | E T F |
1 | Month | County Type Quantity Bundles Cost
2 | 3M1/2008 Genesee Concolor Fir 20000 40 23960
3 | 3M1/2008 Kalkaska Concolor Fir 10000 20/ 11980
4 |3/1/2008 Lake Concolor Fir 12000 24114376
5 | 1/1/2008 Oakland | Concolor Fir 13500 27116173

TIP: If you can’t drill down in a worksheet, the option is disabled in the Table Options dialog box. You can disable
the drill down option when you want to present aggregate data — for example, employee attendance or student
test scores —while keeping the details about individual employees or students confidential.

CHANGING THE SUMMARY AND FORMAT FOR DATA FIELDS

To change the type of summary, click the Field Settings button on the PivotTable toolbar or double-click the
Data field button (not a value, but the button at the upper left corner of the table) to open the PivotTable Field
dialog box. Choose the type of summary you want to use from the list box.

The default number format in a pivot table is General. Click the Number button in the Pivot Table Field dialog
box to change formats, or use the Formatting toolbar and Format Cells dialog box to format the completed pivot
table.

TIP: You might wonder “Why don’t | just select the cells and format them?” You can, but formatting will be
removed the next time you refresh the data in the pivot table. Unless you want practice formatting in Excel, use
the Pivot Table Field dialog box and format the field.

SETTING PIVOT TABLE OPTIONS



Pivot tables are constructed objects. Unlike

a regular worksheet, pivot table rows and PivotTable Options E|
columns are created and populated based Name: | SRR |
on settings. The PivotTable Options dialog St
box is anything but optional. Right-click Grand totals for columns Page layout: |Du:uwn,Then Civer V|
anywhere in the pivot table and choose Grand totals for rows Field umn:
. . AutoFormat table —IE per e
Table Options to open the dialog box. Two _ _
. Subtotal hidden page items
frequently changed options are the grand [ Merge labels [ For error yalues, show: I:I
totals and the empty cells options. Enable Preserve formatting [JFor empty cells, show: | |
the Empty Cells checkbox to suppress the Repeat item labels on each printed  [] Set print titles
. . page
automatic display of zeros for empty pivot
table cells. Data options
Data source options: External data options:
APPLYING AN AUTOFORMAT Save data with table layout
Enable drill to details
[] Refresh on open
There are twenty-two different |:|
AutoFormats designed specifically for pivot
. [ QK ] [ Cancel ]
tables. The first ten AutoFormats (Report 1

- Report 10) are indented formats designed to resemble traditional printed database reports. These PivotTable
Reports look very little like pivot tables, and a lot like reports you’d spend a fair amount of time creating and
formatting in a reporting tool like Business Objects or Crystal Reports.

To apply an AutoFormat, right click on the pivot table and choose Format Report from the shortcut menu or
choose a format from the Design tab of the ribbon.

KEEPING THE PIVOT TABLE UPDATED

A pivot table is dynamically linked to the database used to create the table. If you edit values within the
database, simply click the Refresh Data button on the ribbon and Excel will update the pivot table to reflect the
database changes.

However, if you add columns to the database or add rows of data at the bottom of the database, you cannot
simply refresh the data. You must return to the Pivot Table and PivotChart Wizard and identify the new range of
records that should be included in the table. If you don’t, the pivot table values won’t include the added data.



CREATING A PIVOTTABLE WITH OTHER DATA

You can create a PivotTable with any data you can get into your workbook, including data from another Excel
workbook, SQL Server, a web page, Access, SharePoint, or other data sources. You use Microsoft Query to access
external data and display it in Excel.

1. Inthe first step of the Wizard, choose External Data Source then click Next.
2. Inthe second step of the Wizard, click the Get Data button to open the Choose Data Source dialog box.

3. If your data source exists, select it then click OK. If the source does not exist, choose the source type
from the list on the Database tab then click OK.

The next screens you’ll see depend on your data source. When you have finished entering information, you'll
end up in Microsoft Query. If you will be using this data set in the future, click the Save Query button to name

and save your query. In the future, the query will appear on the Queries tab of the Choose Data Source dialog
box.

CREATING A PIVOTCHART

There are two ways to create a pivot chart:
1. Inthe first step of the Wizard, choose Pivot Chart Report (with Pivot Table Report), or
2. Select an existing pivot table and click the Chart button on the ribbon.

After the chart is created, you can format the chart using the commands on the Chart menu. Manipulate the
chart as you would the pivot table: by dragging field buttons to the Data, Axis, and Legend areas of the chart, or
using the task pane.

ETCETERA

This is just the beginning of what you can do with Excel PivotTables. You can add calculated fields, create custom
calculations, create a separate pivot table for each department or time period in three easy steps...the list is
quite long. For more information look up Pivot Table in Excel help or visit the Microsoft Office web site.
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